
第2章 電子回路シミュレータ

電子回路シミュレータの基礎知識



2.1 電子回路シミュレータの機能

回路設計の基本的なツールである電子回路シミュレータの仕組みと機
能（参考書1-1節参照）
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電子回路シミュレータの構造と機能

回路図エディタ 電子回路シミュ
レータの本体

ポストプロセッサ

シンボルエディタ

ネットリスト シミュレーション結果

• 回路図入力

• 回路図記号（シ
ンボル）の作成

• DC解析
• AC解析
• Transient解析
• Noise解析

• グラフ表示
• データ解析
電流,電圧の測定
各種演算
フーリエ変換など
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（参考） 電子回路シミュレータの本体は、カリフォルニア大学バークレイ校で開発さ
れたSPICE(Simulation Program with Integrated Circuit Emphasis)のソースコードを元
に開発されたものが多い。これらの回路シミュレータをSPICE系シミュレータと呼ぶ。
この他の回路シミュレータは、非SPICEまたはPost-SPICEシミュレータと呼ばれる。

（シンボル = 回路図記号）



前スライドの専門用語
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Schematic: 回路図（Schematic diagram, Circuit diagramという用語もある
がSchematicと呼ぶのが普通）

Symbol: 回路記号
Netlist: ネットリスト（回路図の部品接続情報）
Schematic entry: 回路図入力（Schematic captureも同義）
Circuit simulator: 電子回路シミュレータ
DC analysis: DC解析（または直流解析）
AC analysis: AC解析（または小信号交流解析または周波数特性解析）
Transient analysis: 過渡応答解析（またはトランジェント解析）
Noise analysis: ノイズ解析（またはノイズパワースペクトラム解析）
Postprocessor: ポストプロセッサ（データの可視化処理やフォーマット変換など

を行うソフト）



電子回路シミュレータの主な解析
機能

得られる特性解析の種類

横軸が電圧または電流の特性（SMU, Source 
Measure Unit）

DC解析

横軸が周波数の特性（ネットワークアナライザ）AC解析

横軸が時間の解析（オシロスコープ）Transient解析

横軸が周波数、縦軸が雑音電圧密度Noise解析
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• Transient解析は、他の解析に比べて時間がかかる。トランジスタ数が
1000個以上の場合、高性能PCを使用しても、数日かかることが多い

• 回路を設計するためには、色々な解析法を組み合わせる必要がある。初
心者はTransient解析だけに頼りがちだが、これでは意図通りに動作する
回路を設計できない

実測するとき必要な計測器



デバイスのモデルパラメータ
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L, C, R ダイオード

トランジスタの特性計算には、数10個のパラメータが必要。

キャパシタンス C = 10pF

インダクタンス L = 10nH

抵抗 R = 10kΩ

各デバイスの特性は、最低1個
のパラメータで表せる。→ 回
路図に書き込んでしまう。

飽和電流 Is = 100pA
電位障壁 Vj = 0.65V
エミッション係数 n = 1.2
ゼロバイアス接合容量 Cjo = 100pF
ブレークダウン電圧 BV = 250V・

・
・

特性の計算には多くのパラメー
タが必要。→モデルパラメータ
ファイルに記載してインクルード。



電子回路シミュレータの処理フロー

7

デバイスモデル

回路方程式の数値解法プログラム

回路図エディタ

ポストプロセッサ

回路シミュレー
タ本体

ネットリスト

モデルパラメータファイル

通常は半導体メーカが用意。 ユーザが入力。

モデルパラメータ

シミュレーション結果（テキスト、バイナリ）

LTspiceなどの

統合シミュレー
ション環境

デバイスモデル(Device model)： 半導体デバイスの特性を表す計算式。
モデルパラメータ(Model parameter)： デバイスモデルに含まれるパラメータ。



電子回路シミュレータの限界
• 電子回路シミュレータでシミュレーションできないケース

– 温度が時間変化する場合や、部品によって異なる温度になる場合
はシミュレーションできない

– 過電圧、過電流によるデバイスの破損はシミュレーションできない
• 絶対最大定格（Absolute maximum rating, デバイスが破損する電圧、電流、電
力の限界値）を越えてもシミュレーション上では回路が動作する

• 実際の回路が故障しないためには、絶対最大定格に対する、マージン（設計余
裕度）が必要

• 電子回路シミュレータの精度
– 半導体デバイスのモデルパラメータの精度に依存している

• 代入していないパラメータはデフォルト値になる

– ソルバー（数値計算プログラム）の許容誤差により制限される
• 各種許容誤差を設定可能だが、通常はデフォルトで問題ない
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回路シミュレータは現実とは違うことを理解した上で使用する必要がある。



おまけ：回路図の作成方法

• 宿題で使用するLTspiceに回路図エディタが付属している

が、図として、あまりかっこよくないので、学生実験のレポ
ートなどでは、下記のダイアグラム作成ソフトを試してみ
よう。回路図の他、フローチャート、ネットワークダイアグ
ラムなどもきれいに描けます。

• 使用法の解説ページ

– https://smerl.jp/draw-io/
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2.1節のまとめ
• 電子回路シミュレータは、回路図エディタ、シンボルエディタ、シミュレータ
本体、ポストプロセッサから構成されている

– 回路図エディタはネットリスト（回路の接続情報）を出力し、回路シミュレータ
本体は、ネットリストから回路方程式を作成する

– シミュレータ本体は、カリフォルニア大学が開発したSPICEをベースとしてい
るものが多い

– 主な解析機能にはDC解析（直流電圧、直流電流）、AC解析（周波数領域）、
Transient解析（時間領域）、Noise解析（周波数領域）などがある

• 回路図の他に、デバイスモデルパラメータが必要

– デバイス特性の計算のため、モデルパラメータファイルをインクルードする

– モデルパラメータはデバイス特性の実測値から推定することができるが、デ
バイスモデルに関する専門知識が必要

– 値を与えなかったパラメータがある場合、デフォルト値が使用されるためシミ
ュレーション結果が正確ではない
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2.2 LTSPICEの基本操作

回路図入力～シミュレーション結果の表示まで
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２．２．１ 初期設定
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LTspiceを使いやすくするための準備



初期設定１
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Settings

マイクロをuで表す

（日本語環境での
文字化けを防ぐ）



初期設定２
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斜め配線を不許可（任意）

回路図にグリッド
点を表示（任意）

回路図の自動ス
クロールを禁止
（任意）



初期設定３
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小さいアイコンで表示（任意）

詳細な回路図
データを保存



初期設定４
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プロットと読み取りカー
ソルの線幅を太めに



カラー設定１
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回路図の背景を白に

（任意）
グラフの背景を白に

（必須）

グラフの背景が黒だと印
刷時にグラフが読めない

メニューより [Tools] → [Color preferences]



カラー設定２
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グラフの軸を黒に（任意）

グラフの背景を白にした場合、
軸と目盛り数字を黒にすると、
グラフが読みやすい



２．２．２ 例題：Lチカ回路
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Lチカ回路 ＝ LEDを点滅させる回路



（重要）電源の省略表記
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電源の電圧源と電源配線を省略して、電源配線名VDDま
たはVCC（負電源の場合はVSSまたはVEE）を付けること
により、回路図を読みやすくする。

完全な配線表記 電源配線の省略

（シミュレーション用
の表記）

電源配線と電源の省略
（一般の回路図表記）



NE555（タイマーIC）の内部回路
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2

3
VCC

1

3
VCC

コンパレータ
（電圧比較器）

電源



NE555の構成要素
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Comparator（電圧比較器） BJT (Bipolar  Junction Transistor)

RS-FF (Reset-
set flip-flop)

Inverter

V+

V-
VO

Reset

�� � �	 
 0 → �� � "H"

�� � �	 � 0 → �� � "L"

VBE

��� 
 0.6 → C�E間がON

OUTIN

"H""L"

"L""H"

QQSR

HoldHold00

1010

0101



NE555を用いたタイマーの例
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充電(Set)

初期化(Reset)

2

3
VCC

1

3
VCC

(Normally
-open)



NE555を用いた発振器の例
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充電(Set)

放電(Reset)

2

3
VCC

1

3
VCC



ソフトなLED点灯回路
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充電

ゆっくり電圧上昇

BJTは、VBE > 0.6V あたりで C-E間
がONになるが、さらにVBEを上げる
とICが増加する性質がある。

蛍のようにゆっくり
LEDが点灯

B

E

C

VBE

IC

OUT



（参考） RC回路の特性
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AC解析

Transient解析

遮断角周波数(rad/s)

時定数(s)

振幅が保持でき
る周波数帯域。

充電や放電にかかる大体の時間。
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回路図の作成

• 次頁を参考にLチカの回路図を入力する

• 注意： 初回の保存は、ツールバーのディスクアイコ
ンを使用しないで、メニューの[File] - [Save As] を使
用すること

– ツールバーから保存すると、ファイル名がDraft1.ascのよ

うなデフォルト名になってしまい、後でファイルを探すのが
難しくなる

– 回路図ファイルの拡張子は、.ascとなる。回路図ファイル
をダブルクリックすると、LTspiceを起動することができる
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Lチカの回路図
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回路定数の書き方

1. 定数に単位を付けるとき、数値との間にスペースを空けな
いこと（V, A, F, Hなどの単位は省略可）
• 例1：100fFまたは100f （フェムトファラッド）

• 例2：1mHまたは1m （ミリヘンリー）

2. マイクロはuで表す（※）

3. メガはMEG, ミリはmとする
• SPICE系シミュレータでは大文字と小文字は同じものとして扱われ
るのでMとmの見分けがつかないため
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覚えておこう

※ 3は、回路シミュレータ特有の約束だが、回路技術分野では、マイクロ
を表すために u が使用されることが多い。
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SI接頭辞

• 電子回路で出てくる数
値には、非常に小さい
値や大きい値が多い

• SI接頭辞を用いて表
記を簡略化する（記憶
すること）

指数部読み方記号

1015ペタPET

1012テラT

109ギガG

106メガMEG

103キロk

10-3ミリm

10-6マイクロu

10-9ナノn

10-12ピコp

10-15フェムトf

SI: International System of Units



SI接頭辞の練習
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1. 1/(1MEG) = ?
2. 1/(1m) = ?
3. 1/(1u) = ?
4. 1/(1n) = ?
5. (1MEG)/(1k) = ?
6. (1k)/(1MEG) = ?
7. 1/(1m･1m) = ?
8. 1/(1n + 1n) = ?



Transient解析（横軸＝時間）の設定
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回路図エディタの部品や配線がないスペースを右クリック
→ Configure Analysis を選択
→ Transientタブを設定
→ SPICEコマンドの文字列を回路図エディタ画面に配置
→ 再びスペースを右クリックし、Runでシミュレーション開始

シミュレーションを終了する時間

データの保存を開始する時間
（定常状態の波形を見たい場
合などは、最初の方の結果は
必要ないため。）

時間刻み幅の上限（シミュ
レータは時間刻みを自動
調整している。）

対応するSPICE命令



課題２．１（１）

1. NE555を用いたタイマーのスイッチを入れた後、
出力OUTが 'H' になり続ける時間T1をR1, C1 
の式で表せ

2. NE555を用いた発振器の発振周期T2をR1, R2, 
C1の式で表せ
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課題２．１（２）

3. 参考書２．１節のLチカ回路のシミュレーションを行い、
回路図、結果のグラフをPDFファイルにして提出せよ（
ワープロ等に貼り付けて、PDF出力すればよい）
– 結果のグラフには、I(D1), LEDに加わる電圧, V(BASE), 

V(TRIG), V(OUT)を示すこと

4. シミュレーション結果から、点灯時間TON, 消灯時間
TOFF, 発光周期TPを測定し、それぞれの計算値に対す
る相対誤差(%)を求めよ
– ただし、TONは、V(OUT)が'HIGH'となる時間、TOFFは、V(OUT)
が'LOW'となる時間と定義する。

34



エクスポート
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回路図の出力

シミュレーションデータの出力

回路図エディタで作成した回路図をOfficeソフト等で使用するとき
1. メニュー：Tools →Write to a .emf file
2. 適当なファイル名を付けて保存
3. 保存できる形式はEMF(Enhanced Meta File)のみ

シミュレーション結果（数値）をExcelや他のソフトウェアで使用したいとき
1. 保存したいグラフのウインドウをクリック
2. メニュー：File → Export data as text
3. 保存したい電圧、電流を CTRLキーを押しながら選択し、OKボタン
をクリック

4. ファイル名は、自動的に"回路名.txt"となる（PRN形式）



画面のコピー
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回路図やグラフをコピペしたいとき
1. 回路図をコピーしたい場合は、回路図のウインドウをクリック
2. グラフをコピーしたい場合は、グラフのウインドウをクリック
3. メニュー：Tools → Copy bitmap to Clipboard
4. 貼り付け先でペースト（CTRL + v）を実行

（注意）

1. 表示されているままの形でコピーされるので、予め貼り付け先の
大きさに合わせてから実行すること。

2. 画面表示された図のビットマップデータなので、後で拡大縮小す
るときたなくなるため、図を適切な大きさに拡大縮小してからコ
ピーすること。



Set

Hold

Reset

R1, C1回路の充電特性は、
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課題２．１（１）のヒント
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Reset

SetSet

T2

R1+R2, C1回路の充電特性は、� % � �##(1 � �
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R2, C1回路の放電特性は、� % � �##�
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t = tS0 t = tR1

t = tS1

= tR0

T2

放電開始時刻t
S0

, 放電終了時刻t
S1

, 充電開始時刻t
R0

, 充電終了時刻t
R1

（従って、t
S1

= t
R0
）として、充電時間t

c
と放電時間t

d
を求める。

%. %/

課題２．１（２）のヒント
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3
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� $1  $2 #1ln(2)

V(t) = VCCとなる時刻を t = 0 とおいて、充電特性の式を用いると、

V(t) = 0となる時刻を t = 0 とおいて、放電特性の式を用いると、

放電時間は、%/ � %�� � %�1 � $2#1 ln 3 � ln
3

2
� $2#1ln(2)

発振周期は、&" � %.  %/ � $1  2$2 #1ln(2)
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２．２．３ 例題：エナジーハーベ
スティング
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エナジーハーベスティング(Energy Harvesting)
＝ 環境エネルギーの電力への変換



エナジーハーベスティング回路
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発電素子
• 太陽電池
• 熱電素子
• 振動発電素子など

PMIC (Power Management IC) 

整流
電圧検出

DC-DC変換 マイコン
センサ

アクチュエータ
無線通信

電気エネルギー

制御信号

充電状態
CHARGE

出力安定状態
OPGOOD

動作モード
SLEEP

環境エネルギー



太陽電池(Solar cell)の等価回路
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V

I

光エネルギー

PMICは、電力（面積）が最大になるよう
に制御している

(MPPT: Maximum Power Point Tracking)

光電流

（シャント）

半導体や電
極の抵抗



太陽電池のモデル

• 発電素子のような特殊な部品は、回路シミ
ュレーション用のモデルが無い場合が多い
ため、等価回路を作成して、データシート
の特性と合わせ込む必要がある

• 参考書３－１またはスライド45を参考に、
太陽電池の等価回路を入力する
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DC解析（横軸=電圧）の設定
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回路図エディタの部品や配線がないスペースを右クリック
→ Configure Analysis を選択し、DC sweepタブに設定を行う
→ SPICE命令の文字列(.dc~)を回路図エディタ画面に配置
→ 再びスペースを右クリックし、Runでシミュレーション開始

変化させたい電圧源の名前

電圧変化のさせ方

開始と終了電圧

変化の間隔

対応するSPICE命令



パラメータスイープ(Parameter sweep)
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.meas (.measurement) 命令で自動測
定を行う。
• Pmax 最大電力
• Vmax 最大電力となる電圧
• Imax 最大電力となる電流

.step 命令で変数値を指定する。
変数は、{Igen}のように{}で囲む。

素子値を変化させて特性変
化を解析することをパラメー
タスイープと呼ぶ。

命令（ディレクティブ）の入力
は、.opアイコンをクリック。



波形演算
• グラフの上で右クリック

• Add Plot Pane Belowを選択

• 追加された空のグラフ枠内
を右クリック

• Add Tracesを選択

• Expression(s) to add:欄に
V(A)*I(V1)を入力
– ALTを押しながらV1をクリック
でも、電力表示できる

• 表示されたグラフの縦軸の
数字をクリックして、Top = 
600mW, Bottom=-100mWに
変更 46

求めたい値の計算式を入力



.measの結果の確認

• グラフまたは回路図の上で
右クリック

• ポップアップメニューから
[View] - [SPICE Output Log] 
を選択

• SPICE Output Logウインドウ
が開き、結果が表示される
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ネットリスト
• 回路の接続情報を表すデータをネットリスト(Netlist)と呼ぶ

– 回路図エディタは、回路図をネットリストに変換する

– 回路シミュレータは、ネットリストに基づき回路方程式を作成する

• LTspiceでシミュレーションを実行すると、拡張子 .ascおよび
.netというファイルが作成される
– *.asc: 回路図エディタのデータ（ダブルクリックで回路図エディタ起動）

– *.net: ネットリスト（SPICE形式）

• 保存した *.net ファイルをテキストエディタで開いてみよう
– ネットリストは、LTspice終了時に削除される（デフォルト設定の場合）

– ネットリストを保存したい場合は、メニュー：View → SPICE Netlist

– ネットリストが表示されるので、ネットリスト上を右クリック→ Generate 
Expanded Listingで保存（この場合は、拡張子 .spとなる）
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SPICEネットリストのフォーマット
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* J:¥Lecture¥Ec2¥2016¥cir2016¥1.3.4.asc
Iph 0 N001 {Igen}
Rsh N001 0 300
Rs A N001 0.1
V1 A 0 0V
D1 N001 N002 Dsc
D2 N002 N003 Dsc
D3 N003 0 Dsc
.model Dsc D(Is=80n Rs=0.1 N=1.9)
.dc V1 0 2.4 10mV
.step param Igen list 0mA 100mA 200mA 300mA
.backanno
.end

行頭の*はコメント行。

Rshがノード"N001"と
ノード"0"の間に接続

されている。抵抗値
は300Ω。ノード番号
'0'は、GND(Ground)
を表す。

.で始まる行はシミュ

レータに渡す命令行
(SPICE Directive)。



（参考）ネットリストを使う場面

• SPICEネットリストは標準的なフォーマットなので、他の電子
回路シミュレータでも読み込める

• シミュレーションエラーが発生したときに、ネットリストが読
めると、原因の特定がしやすい

• マイクロマシン、論理回路、プログラム、新型デバイスなど
を言語記述によりモデリングし、アナログ回路との混在シミ
ュレーションをする場合にSPICEネットリストが使用できる
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課題２．２

1. 参考書３－２，３－３または次ページを参考にし
て、環境発電回路のシミュレーションを行い、回
路図、結果のグラフをPDFにして提出せよ。グラ
フには、V(VDD), V(IN), V(LDO), V(MPPC), 
V(PGOOD), V(AUX), I(L1), I(R5)を示すこと。

– 負荷抵抗R5の抵抗値Rは、$ �名列番号 50 とす
ること。(例）名列番号50の場合$ � 100。

– Transient解析（横軸＝時間の解析）の設定方法、回

路図のコピー方法、グラフのコピー方法は、スライド
p.32, p.36 を参考にすること。
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2.2節のまとめ

• LTspiceの基本的な使い方

– デバイス（シンボル）の配置、配線

– 素子値の設定

– 半導体デバイスモデルとモデル名の指定

– 電圧源、電流源の設定

– 解析の設定（.DC,  .TRAN命令の設定）

– グラフ表示

– 回路図とシミュレーション結果のエクスポート

• LTspiceの少し高度な使い方

– .stepによるパラメトリック解析

– .measによる自動測定

– 波形演算機能によるシミュレーション結果に対する演算

– ネットリストの出力
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